This site uses cookies for analytics. By continuing to browse this site, you agree to this use.

Changelog

December 4, 2019

@hint/formatter-html - 4.1.13

Bug fixes / Improvements

  • [51c16daf6c] - Fix: Restore hint status in formatter-html.

December 3, 2019

hint - 6.0.1

Bug fixes / Improvements

  • [5e922dda5a] - Fix: Normalize hints when extending.

@hint/vscode-webhint - 1.5.1

@hint/connector-puppeteer - 2.4.2

Bug fixes / Improvements

@hint/extension-browser - 2.0.1

@hint/formatter-html - 4.1.12

Bug fixes / Improvements

@hint/hint-amp-validator - 2.10.1

New features

@hint/hint-axe - 4.3.1

Bug fixes / Improvements

@hint/hint-typescript-config - 2.4.1

Bug fixes / Improvements

  • [1b55e3e130] - Fix: Validate target prop only if browserlist configuration exists (see also: #3388).
  • [f7e9b83d60] - Fix: Update schema to draft-07.

@hint/parser-typescript-config - 2.4.2

Bug fixes / Improvements

  • [1b55e3e130] - Fix: Validate target prop only if browserlist configuration exists (see also: #3388).
  • [f7e9b83d60] - Fix: Update schema to draft-07.

December 2, 2019

hint - 6.0.0

Breaking Changes

  • [d59be96330] - Breaking: Group types with utils implementation (see also: #2392).
  • [39d824913a] - Breaking: Remove shortcuts to @hint/utils from hint (see also: #3166).
  • [910c381ca4] - Breaking: Use telemetry instead of tracking (see also: #2995).
  • [03379616e5] - Breaking: Drop support for node 8 (see also: #3140).
  • [c177cc96e8] - Breaking: Remove json specific parser form hint.
  • [e1da45b47b] - Breaking: Remove shortcuts from hint.
  • [31472bb59a] - Breaking: Remove types moved to @hint/utils-types.

New features

  • [43a3daa4b7] - New: Make Severity mandatory.
  • [d62df35cb7] - New: Severity with “default” value for hints.
  • [a7278f2f78] - New: More severities and threshold in schema (see also: #3065).

Bug fixes / Improvements

  • [42b40b58fa] - Fix: Better error reporting when an exception happens.
  • [b628eb4a03] - Fix: Hide configuration-all from the user (see also: #3097).
  • [7ea9591f38] - Fix: Schema and Types for hints (see also: #3348).
  • [7ee688a1b1] - Fix: Use flattened utils.
  • [c86f21a0aa] - Fix: Respect user’s severity.

Chores

  • [abf2ded5b1] - Upgrade: Bump optionator from 0.8.2 to 0.8.3.
  • [ff322d374c] - Upgrade: Bump @types/node from 12.12.7 to 12.12.12.
  • [7c72e1a7c3] - Chore: Change configurations message (see also: #3368).
  • [2c60ff85bd] - Chore: Change unreleased packages version to 0.0.1.
  • [5ef883ef1d] - Upgrade: Bump eslint from 6.5.1 to 6.6.0.
  • [9142edc7d3] - Upgrade: Bump eslint-plugin-markdown from 1.0.0 to 1.0.1.
  • [a112f4b99b] - Chore: Update formatters to support new severity values (see also: #3182, and #3345).
  • [d3cd39bb2f] - Chore: Change Severity enum values (see also: #3344).
  • [65bdae322e] - Chore: Add missing configuration option in schema validation.
  • [90210e7c1e] - Chore: Update references to use generateHTMLPage.
  • [0d37aded21] - Chore: Update packages to use @hint/utils-string.
  • [370cc143b6] - Chore: Update packages to use @hint/utils-tests-helpers.
  • [be6b5025a8] - Chore: Simplify path to utils.
  • [12f5cbadb9] - Chore: Update packages to use @hint/utils-json.
  • [5ed37ce719] - Chore: Update packages to use @hint/utils-fs.
  • [baa55a4ebd] - Chore: Update packages to use @hint/utils-network.
  • [d95dc4a371] - Chore: Update packages to use @hint/utils-dom.
  • [97bb31d0fa] - Chore: Update references to the new @hint/utils-types.
  • [45f015dea0] - Chore: Update packages to use @hint/utils-debug.
  • [c3b2de3f1a] - Upgrade: Bump browserslist from 4.7.0 to 4.7.2.

@hint/vscode-webhint - 1.5.0

New features

  • [618e13aaf7] - New: Add 28-day retention telemetry.
  • [a7278f2f78] - New: More severities and threshold in schema (see also: #3065).

Bug fixes / Improvements

  • [24f54fd854] - Fix: Add getUserConfig to the try/catch block (see also: #3386).
  • [d22e46d316] - Docs: Improve VS Code readme and take it out of preview (see also: #1537).
  • [7e77a1349e] - Fix: Stability issues with VS Code extension.
  • [1c6e51b831] - Fix: Use VS Code language ID to reduce file type telemetry noise (see also: #3289).

Chores

  • [ff322d374c] - Upgrade: Bump @types/node from 12.12.7 to 12.12.12.
  • [422fd3f4f6] - Upgrade: Bump vsce from 1.68.0 to 1.69.0.
  • [f044c9b5a1] - Chore: Update references to old methods/types in hint.
  • [2c60ff85bd] - Chore: Change unreleased packages version to 0.0.1.
  • [5ef883ef1d] - Upgrade: Bump eslint from 6.5.1 to 6.6.0.
  • [9142edc7d3] - Upgrade: Bump eslint-plugin-markdown from 1.0.0 to 1.0.1.
  • [e6e47c71ca] - Upgrade: Bump webpack from 4.39.3 to 4.41.2.
  • [c901412e50] - Chore: Remap VS Code severity.
  • [3f9aec8a79] - Chore: Use shared instrumentation key in VS Code.
  • [8b1803a77d] - Upgrade: Bump webpack-cli from 3.3.9 to 3.3.10.
  • [97bb31d0fa] - Chore: Update references to the new @hint/utils-types.

@hint/configuration-accessibility - 2.0.0

Breaking Changes

  • [9266b187e3] - Breaking: Update configurations to use defaults.

Bug fixes / Improvements

Chores

  • [e9172328e7] - Chore: Drop engine field in package.json.

@hint/configuration-development - 8.0.0

Breaking Changes

  • [9266b187e3] - Breaking: Update configurations to use defaults.

New features

  • [362845f2c1] - New: Add formatter-json to default configs (see also: #3364).

Chores

  • [e9172328e7] - Chore: Drop engine field in package.json.

@hint/configuration-progressive-web-apps - 7.0.0

Breaking Changes

  • [9266b187e3] - Breaking: Update configurations to use defaults.

Chores

  • [e9172328e7] - Chore: Drop engine field in package.json.

@hint/configuration-web-recommended - 8.0.0

Breaking Changes

  • [9266b187e3] - Breaking: Update configurations to use defaults.

New features

  • [362845f2c1] - New: Add formatter-json to default configs (see also: #3364).

Chores

  • [e9172328e7] - Chore: Drop engine field in package.json.

@hint/connector-jsdom - 4.1.1

Bug fixes / Improvements

Chores

  • [ff322d374c] - Upgrade: Bump @types/node from 12.12.7 to 12.12.12.
  • [2c60ff85bd] - Chore: Change unreleased packages version to 0.0.1.
  • [5ef883ef1d] - Upgrade: Bump eslint from 6.5.1 to 6.6.0.
  • [9142edc7d3] - Upgrade: Bump eslint-plugin-markdown from 1.0.0 to 1.0.1.
  • [e9172328e7] - Chore: Drop engine field in package.json.
  • [90210e7c1e] - Chore: Update references to use generateHTMLPage.
  • [33f81543d8] - Upgrade: Bump jsdom from 15.2.0 to 15.2.1.
  • [370cc143b6] - Chore: Update packages to use @hint/utils-tests-helpers.
  • [5ed37ce719] - Chore: Update packages to use @hint/utils-fs.
  • [baa55a4ebd] - Chore: Update packages to use @hint/utils-network.
  • [d95dc4a371] - Chore: Update packages to use @hint/utils-dom.
  • [45f015dea0] - Chore: Update packages to use @hint/utils-debug.

@hint/connector-local - 3.2.1

Bug fixes / Improvements

Chores

  • [ff322d374c] - Upgrade: Bump @types/node from 12.12.7 to 12.12.12.
  • [2c60ff85bd] - Chore: Change unreleased packages version to 0.0.1.
  • [5ef883ef1d] - Upgrade: Bump eslint from 6.5.1 to 6.6.0.
  • [9142edc7d3] - Upgrade: Bump eslint-plugin-markdown from 1.0.0 to 1.0.1.
  • [e9172328e7] - Chore: Drop engine field in package.json.
  • [33f81543d8] - Upgrade: Bump jsdom from 15.2.0 to 15.2.1.
  • [a4a056d234] - Upgrade: Bump chokidar from 3.2.3 to 3.3.0.
  • [5ed37ce719] - Chore: Update packages to use @hint/utils-fs.
  • [baa55a4ebd] - Chore: Update packages to use @hint/utils-network.
  • [d95dc4a371] - Chore: Update packages to use @hint/utils-dom.
  • [1f4b600a43] - Chore: Update packages to use @hint/utils-i18n.
  • [711b849d55] - Upgrade: Bump chokidar from 3.0.2 to 3.2.3.

@hint/connector-puppeteer - 2.4.1

Bug fixes / Improvements

Chores

  • [ff322d374c] - Upgrade: Bump @types/node from 12.12.7 to 12.12.12.
  • [34bd5dc265] - Chore: Move chromium-finder utils to puppeteer.
  • [2c60ff85bd] - Chore: Change unreleased packages version to 0.0.1.
  • [5ef883ef1d] - Upgrade: Bump eslint from 6.5.1 to 6.6.0.
  • [9142edc7d3] - Upgrade: Bump eslint-plugin-markdown from 1.0.0 to 1.0.1.
  • [e9172328e7] - Chore: Drop engine field in package.json.
  • [90210e7c1e] - Chore: Update references to use generateHTMLPage.
  • [1ee0419dbb] - Upgrade: Bump puppeteer-core from 1.20.0 to 2.0.0.
  • [370cc143b6] - Chore: Update packages to use @hint/utils-tests-helpers.
  • [5ed37ce719] - Chore: Update packages to use @hint/utils-fs.
  • [baa55a4ebd] - Chore: Update packages to use @hint/utils-network.
  • [d95dc4a371] - Chore: Update packages to use @hint/utils-dom.
  • [45f015dea0] - Chore: Update packages to use @hint/utils-debug.

@hint/extension-browser - 2.0.0

Breaking Changes

  • [9266b187e3] - Breaking: Update configurations to use defaults.
  • [8ed008ffe9] - Breaking: Remove chromium-finder from @hint/utils.

New features

  • [fb663cc76d] - New: Update browser extension to support new severity values (see also: #3181, and #3340).

Bug fixes / Improvements

  • [905ef61419] - Fix: Severity icon color.
  • [927967b1ae] - Fix: Information position in minimum hint severity section (see also: #3375).
  • [9806266ad6] - Fix: Syntax highlighting color incorrect for Edge (see also: #3270).
  • [7ee688a1b1] - Fix: Use flattened utils.

Chores

  • [ff322d374c] - Upgrade: Bump @types/node from 12.12.7 to 12.12.12.
  • [65fd31c70e] - Upgrade: Bump react from 16.10.2 to 16.12.0.
  • [afa82f7eed] - Chore: Increase error color contrast (see also: #3365).
  • [f044c9b5a1] - Chore: Update references to old methods/types in hint.
  • [2c60ff85bd] - Chore: Change unreleased packages version to 0.0.1.
  • [5ef883ef1d] - Upgrade: Bump eslint from 6.5.1 to 6.6.0.
  • [9142edc7d3] - Upgrade: Bump eslint-plugin-markdown from 1.0.0 to 1.0.1.
  • [e6e47c71ca] - Upgrade: Bump webpack from 4.39.3 to 4.41.2.
  • [d64ecd6130] - Upgrade: Bump @types/react from 16.9.9 to 16.9.11.
  • [4cfa0be336] - Upgrade: Bump react-dom from 16.11.0 to 16.12.0.
  • [f37743ef48] - Upgrade: Bump web-ext from 3.2.0 to 3.2.1.
  • [e9172328e7] - Chore: Drop engine field in package.json.
  • [2dfc8d6afd] - Chore: Used shared instrumentation key in the browser.
  • [c2f74dc1a3] - Chore: Migrate to shared telemetry utilities.
  • [b6182f427f] - Upgrade: Bump glob from 7.1.5 to 7.1.6.
  • [8b1803a77d] - Upgrade: Bump webpack-cli from 3.3.9 to 3.3.10.
  • [1fc5d690bf] - Upgrade: Bump eslint-plugin-react-hooks from 2.1.2 to 2.2.0.
  • [33f81543d8] - Upgrade: Bump jsdom from 15.2.0 to 15.2.1.
  • [ef9300f80b] - Upgrade: Bump terser-webpack-plugin from 2.1.2 to 2.2.1.
  • [1ee0419dbb] - Upgrade: Bump puppeteer-core from 1.20.0 to 2.0.0.
  • [be6b5025a8] - Chore: Simplify path to utils.
  • [5ed37ce719] - Chore: Update packages to use @hint/utils-fs.
  • [baa55a4ebd] - Chore: Update packages to use @hint/utils-network.
  • [d95dc4a371] - Chore: Update packages to use @hint/utils-dom.
  • [97bb31d0fa] - Chore: Update references to the new @hint/utils-types.
  • [1f4b600a43] - Chore: Update packages to use @hint/utils-i18n.
  • [f4973d08e3] - Upgrade: Bump react-dom from 16.10.2 to 16.11.0.
  • [7c67bddcf5] - Upgrade: Bump glob from 7.1.4 to 7.1.5.
  • [c3b2de3f1a] - Upgrade: Bump browserslist from 4.7.0 to 4.7.2.